aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..9a1e680
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,6 @@
+project('stargaze', 'c', license: 'GPL-3', version: '0.1')
+
+add_project_arguments('-DDATADIR="@0@/share"'.format(get_option('prefix')), language: 'c')
+notcurses_dep = dependency('notcurses-core')
+executable('stargaze', 'main.c', dependencies: notcurses_dep, install: true)
+install_subdir('stargaze', install_dir: 'share')