aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-11-09 16:58:59 +0100
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-11-13 03:54:48 +0100
commitb61f6f4d53803ecf83d9d6152a48bc39c1f2dd42 (patch)
treef8f68b649c39e61aceb1afdae8eaa5afb081ffd0 /meson.build
init
Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..9a1e680
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,6 @@
+project('stargaze', 'c', license: 'GPL-3', version: '0.1')
+
+add_project_arguments('-DDATADIR="@0@/share"'.format(get_option('prefix')), language: 'c')
+notcurses_dep = dependency('notcurses-core')
+executable('stargaze', 'main.c', dependencies: notcurses_dep, install: true)
+install_subdir('stargaze', install_dir: 'share')