aboutsummaryrefslogtreecommitdiff
path: root/src/supervise-daemon/meson.build
diff options
context:
space:
mode:
authorLexxy Fox <lexxyfox@gmail.com>2023-09-26 13:30:14 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2023-10-03 16:43:39 -0500
commitcf9286d2d84f7aef237ec0d363c692ef5035aa85 (patch)
tree7827b9bf3f477c3de0d5f225acc0818d020f0c57 /src/supervise-daemon/meson.build
parent9934e9f96ea91995dfab382bf05b47d43c1ac4f9 (diff)
Relocate pipes.c and pipes.h file to shared directory.
With the addition of logger process redirect in supervise-daemon, pipes.c and pipes.h are now included in both s-s-d and supervise-daemon. Thus it makes sense to move the source files to the src/shared dir.
Diffstat (limited to 'src/supervise-daemon/meson.build')
-rw-r--r--src/supervise-daemon/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/supervise-daemon/meson.build b/src/supervise-daemon/meson.build
index f7d70c4c..9ef0fd86 100644
--- a/src/supervise-daemon/meson.build
+++ b/src/supervise-daemon/meson.build
@@ -1,5 +1,5 @@
executable('supervise-daemon',
- ['supervise-daemon.c', '../start-stop-daemon/pipes.c', misc_c, plugin_c, schedules_c, usage_c, version_h],
+ ['supervise-daemon.c', pipes_c, misc_c, plugin_c, schedules_c, usage_c, version_h],
c_args : [cc_branding_flags, cc_pam_flags, cc_cap_flags, cc_selinux_flags],
link_with: [libeinfo, librc],
dependencies: [dl_dep, pam_dep, cap_dep, util_dep, selinux_dep],