aboutsummaryrefslogtreecommitdiff
path: root/src/supervise-daemon/meson.build
diff options
context:
space:
mode:
authorLexxy Fox <lexxyfox@gmail.com>2023-09-25 17:33:22 -0500
committerWilliam Hubbs <w.d.hubbs@gmail.com>2023-10-03 16:43:39 -0500
commit9934e9f96ea91995dfab382bf05b47d43c1ac4f9 (patch)
treea6f3bc377be9506ab8126f91827b9cb243c3f918 /src/supervise-daemon/meson.build
parentf1e5510ccf06a2e0ea61a2de2e764ddc6a7b1d5d (diff)
supervise-daemon: implement output_logger and error_logger.
Allows redirecting process stdin and stdout to another process, just like is already possible with start-stop-daemon. Also added --stdout-logger and --stderr-logger to the man page.
Diffstat (limited to 'src/supervise-daemon/meson.build')
-rw-r--r--src/supervise-daemon/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/supervise-daemon/meson.build b/src/supervise-daemon/meson.build
index 808114f0..f7d70c4c 100644
--- a/src/supervise-daemon/meson.build
+++ b/src/supervise-daemon/meson.build
@@ -1,5 +1,5 @@
executable('supervise-daemon',
- ['supervise-daemon.c', misc_c, plugin_c, schedules_c, usage_c, version_h],
+ ['supervise-daemon.c', '../start-stop-daemon/pipes.c', misc_c, plugin_c, schedules_c, usage_c, version_h],
c_args : [cc_branding_flags, cc_pam_flags, cc_cap_flags, cc_selinux_flags],
link_with: [libeinfo, librc],
dependencies: [dl_dep, pam_dep, cap_dep, util_dep, selinux_dep],