aboutsummaryrefslogtreecommitdiff
path: root/skel.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/skel.ebuild b/skel.ebuild
new file mode 100644
index 0000000..f71ff8c
--- /dev/null
+++ b/skel.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+inherit neovim-plugin
+
+DESCRIPTION="@DESCRIPTION@"
+HOMEPAGE="@URI@"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="@SRC@"
+else
+ SRC_URI="https://github.com/@PLUGIN@/archive/refs/tags/v${PV}.tar.gz"
+fi
+
+LICENSE="@LICENSE@"
+SLOT="0"
+
+KEYWORDS="~amd64"