aboutsummaryrefslogtreecommitdiff
path: root/skel.ebuild
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-05 18:59:35 +0100
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-05 19:02:02 +0100
commit23544e126419753893f48082960796b65e60fc93 (patch)
treea5e4563270cf30ff9530bf6b65379563c995c7f0 /skel.ebuild
first batch of pluginsHEADmain
Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/skel.ebuild b/skel.ebuild
new file mode 100644
index 0000000..f71ff8c
--- /dev/null
+++ b/skel.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+inherit neovim-plugin
+
+DESCRIPTION="@DESCRIPTION@"
+HOMEPAGE="@URI@"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="@SRC@"
+else
+ SRC_URI="https://github.com/@PLUGIN@/archive/refs/tags/v${PV}.tar.gz"
+fi
+
+LICENSE="@LICENSE@"
+SLOT="0"
+
+KEYWORDS="~amd64"