summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 16 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4c0c163..d43414f 100644
--- a/meson.build
+++ b/meson.build
@@ -64,10 +64,24 @@ frag_shader = custom_target(
command: [find_program('glslc'), '@INPUT@', '-o', '@OUTPUT@']
)
-c_files += [ vert_shader, frag_shader ]
+combine_vert = custom_target(
+ input: 'shaders/combine.vert',
+ output: '@PLAINNAME@',
+ command: [find_program('glslc'), '@INPUT@', '-o', '@OUTPUT@']
+)
+
+combine_frag = custom_target(
+ input: 'shaders/combine.frag',
+ output: '@PLAINNAME@',
+ command: [find_program('glslc'), '@INPUT@', '-o', '@OUTPUT@']
+)
+
+c_files += [ vert_shader, frag_shader, combine_vert, combine_frag ]
executable('vk', c_files, dependencies: libs, include_directories: ['include/'],
c_args: [
'-DVERTEX_SHADER="@0@"'.format(vert_shader.full_path()),
- '-DFRAGMENT_SHADER="@0@"'.format(frag_shader.full_path())
+ '-DFRAGMENT_SHADER="@0@"'.format(frag_shader.full_path()),
+ '-DBLEND_VERT="@0@"'.format(combine_vert.full_path()),
+ '-DBLEND_FRAG="@0@"'.format(combine_frag.full_path())
])