aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKenny Levinsen <kl@kl.wtf>2020-07-31 14:19:41 +0200
committerKenny Levinsen <kl@kl.wtf>2020-07-31 14:19:41 +0200
commit9d08511da4d9860a8b78ef38899499123401a80c (patch)
tree8bf5b7bb54c96d441b9f3c1acdb836e794ff3a85 /meson.build
parent1d188d2f09bb272feb11ad56de7594fb1ac58fdc (diff)
meson: Add summary printout
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9f7c9a8..be2c365 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project(
'seatd',
'c',
version: '0.1',
- meson_version: '>=0.47.0',
+ meson_version: '>=0.53.0',
default_options: [
'c_std=c11',
'warning_level=3',
@@ -90,14 +90,17 @@ if get_option('seatd').enabled()
add_project_arguments('-DSEATD_ENABLED=1', language: 'c')
endif
+logind_provider = ''
if get_option('logind').enabled()
logind = dependency('libsystemd', required: false)
add_project_arguments('-DLOGIND_ENABLED=1', language: 'c')
if logind.found()
add_project_arguments('-DHAVE_SYSTEMD=1', language: 'c')
+ logind_provider = 'systemd'
else
logind = dependency('libelogind')
add_project_arguments('-DHAVE_ELOGIND=1', language: 'c')
+ logind_provider = 'elogind'
endif
private_files += [
@@ -155,3 +158,10 @@ if get_option('examples').enabled()
install: false,
)
endif
+
+summary({
+ 'seatd': get_option('seatd').enabled() ? 1 : 0,
+ 'builtin': get_option('builtin').enabled() ? 1 : 0,
+ 'systemd': logind_provider == 'systemd' ? 1 : 0,
+ 'elogind': logind_provider == 'elogind' ? 1 : 0,
+})