aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-03-26 10:05:12 +0100
committerKenny Levinsen <kl@kl.wtf>2021-03-26 11:11:26 +0100
commit9a7824b7c3ff5c957632671e91454fc84fbcdda8 (patch)
treecf103f2f5591943b61cb330e129e20de546477ea /meson.build
parent5ad91ae9dad205331ede6579b2b24b53e02a6287 (diff)
Add no-op session
This is useful for headless testing, for instance with VKMS: modprobe vkms export WLR_DRM_DEVICES=/dev/dri/card1 export WLR_BACKENDS=drm export LIBSEAT_BACKEND=noop sway We don't need any of the VT handling in this case.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f41b621..c3800ae 100644
--- a/meson.build
+++ b/meson.build
@@ -145,7 +145,7 @@ symbols_file = 'libseat/libseat.syms'
symbols_flag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), symbols_file)
lib = library(
'seat', # This results in the library being called 'libseat'
- [ 'libseat/libseat.c' ],
+ [ 'libseat/libseat.c', 'libseat/backend/noop.c' ],
soversion: libseat_soversion,
link_with: private_lib,
include_directories: [include_directories('.', 'include')],