aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-03-11 13:56:57 +0000
committerKenny Levinsen <kl@kl.wtf>2023-03-13 17:06:31 +0100
commit3e0d510b2c46eb18ab7239b029e01475eb2e3810 (patch)
tree258ab68ab0ffd287bb605a26794fda999540950b /meson.build
parent207e2a59363037c192278bc51e3693d88d115514 (diff)
meson: fix seatdpath with absolute bindir
Quoting the Meson documentation: > Note that the value returned for built-in options that end in `dir` > such as `bindir` and `libdir` is usually a path relative to (and > inside) the `prefix` but you should not rely on that, as it can also > be an absolute path [in some cases](Builtin-options.md#universal-options). > [`install_dir` arguments](Installing.md) handle that as expected > but if you need an absolute path, e.g. to use in a define etc., > you should use the path concatenation operator like this: > `get_option('prefix') / get_option('localstatedir')`. > Never manually join paths as if they were strings. The concatenation of two absolute paths caused seatd-launch in Nixpkgs to try to launch e.g. /nix/store/43wyk9s2l2z8cparnshbf24d39vm5272-seatd-0.7.0//nix/store/j9a7k4qqwc3byyfmpqwg46shmh6g82yf-seatd-0.7.0-bin/bin/seatd.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 661b39a..0c6c823 100644
--- a/meson.build
+++ b/meson.build
@@ -22,7 +22,7 @@ if defaultpath == ''
endif
endif
-seatdpath = '@0@/@1@/seatd'.format(get_option('prefix'), get_option('bindir'))
+seatdpath = get_option('prefix') / get_option('bindir') / 'seatd'
cc = meson.get_compiler('c')