aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKenny Levinsen <kl@kl.wtf>2021-08-06 00:06:44 +0200
committerKenny Levinsen <kl@kl.wtf>2021-08-06 01:29:52 +0200
commit1e98727ae9dfdb23316249a4f32b3169d956e417 (patch)
tree9d886b4708cf7d9bfac266fc7a494c0f5b4cd347 /meson.build
parentc8b3a22d4ef0f69c3d22f0ec1170b89c93ef1dc3 (diff)
seatd-launch: Add seatd launch wrapper
This launch wrapper is used to conveniently start a new seatd instance, wait for it to be ready, and launch a target application.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9d48706..1131b4b 100644
--- a/meson.build
+++ b/meson.build
@@ -204,6 +204,13 @@ if with_server
install: true,
dependencies: [realtime],
)
+ executable(
+ 'seatd-launch',
+ [ 'seatd-launch/seatd-launch.c' ],
+ include_directories: [include_directories('.', 'include')],
+ install: true,
+ dependencies: [realtime],
+ )
endif
if get_option('examples') == 'enabled'