aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index dc1a3fd8..4e330d33 100644
--- a/meson.build
+++ b/meson.build
@@ -83,16 +83,9 @@ else
pkg_prefix = option_pkg_prefix
endif
-if get_option('split-usr') == 'auto'
- split_usr = run_command('test', '-L', '/bin', check: false).returncode() != 0
-else
- split_usr = get_option('split-usr') == 'true'
-endif
-
rootprefix = get_option('rootprefix')
-rootprefix_default = fs.is_symlink('/bin') ? '/usr' : '/'
if rootprefix == ''
-rootprefix = rootprefix_default
+rootprefix = '/'
endif
bindir = rootprefix / get_option('bindir')