aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-20 12:06:37 +0000
committerWilliam Hubbs <w.d.hubbs@gmail.com>2021-11-20 17:33:14 -0600
commitf3f0fde861b438c80f99afdd49fe175e9d0a68ca (patch)
tree0ec1e0fcd03442ba482c1f932cf9485772ca99f5 /meson.build
parentbd5cdaafadf997c0ab3c4ad362dbdfd7dc6fd987 (diff)
meson: link against libcrypt for SELinux if no PAM
We use libcrypt's crypt() if we're _not_ using PAM in the SELinux code (rc-selinux, specifically). X-Gentoo-Bug: 824954 X-Gentoo-Bug-URL: https://bugs.gentoo.org/824954 Fixes: https://github.com/openrc/openrc/pull/477
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8af45560..1ee10751 100644
--- a/meson.build
+++ b/meson.build
@@ -93,6 +93,8 @@ rc_bindir = rc_libexecdir / 'bin'
rc_sbindir = rc_libexecdir / 'sbin'
sbindir = rootprefix / get_option('sbindir')
+crypt_dep = dependency('libcrypt', required : not get_option('pam'))
+
selinux_dep = dependency('libselinux', required : get_option('selinux'))
pam_misc_dep = []
if selinux_dep.found()