aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2021-12-30 18:45:39 -0600
committerWilliam Hubbs <w.d.hubbs@gmail.com>2021-12-30 18:45:39 -0600
commit5e9797035b4c26550e61e1aa0e3ad6c01a738bb2 (patch)
tree10c61e0940333aaf1f250cc8c1bcd8570038903c /meson.build
parentc045d33a40cad626eebc2381daf58eba8ca79343 (diff)
fix libkvm dependency for *bsd
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bd96c7d3..bbbd93e2 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,12 @@ else
os = option_os
endif
+if os != 'Linux'
+ kvm_dep = cc.find_library('kvm', required: true)
+else
+ kvm_dep = []
+endif
+
pam_dep = dependency('pam', required: false)
if not pam_dep.found()
pam_dep = cc.find_library('pam', required: false)