aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2024-02-20 00:17:56 -0600
committerWilliam Hubbs <w.d.hubbs@gmail.com>2024-03-31 23:13:02 -0500
commit536794dfad33be978c7b1f8005c899c8d4ce2fa6 (patch)
treecf8128672506367de50681f2dd1fe4df05a438f7 /meson.build
parent7ac2080e314b1203bfc25769209e6033f4d09d6e (diff)
Trivial curses/termcap removal
Remove the curses code and make the HAVE_TERMCAP-gated "fallbacks" always present. This makes an ANSI terminal required for colors. X-Gentoo-Bug: https://bugs.gentoo.org/904277 Closes: https://github.com/OpenRC/openrc/issues/619
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 0 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 4e330d33..93186887 100644
--- a/meson.build
+++ b/meson.build
@@ -126,15 +126,6 @@ else
cc_selinux_flags = []
endif
-termcap = get_option('termcap')
-if termcap != ''
- termcap_dep = dependency(termcap)
- termcap_flags = '-DHAVE_TERMCAP'
- else
- termcap_dep = []
- termcap_flags = []
-endif
-
if get_option('buildtype').startswith('debug')
cc_debug_flags = ['-DRC_DEBUG']
else