aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNikolaos Chatzikonstantinou <nchatz314@gmail.com>2022-10-22 15:35:29 -0400
committerWilliam Hubbs <w.d.hubbs@gmail.com>2022-12-08 11:06:09 -0600
commit35077afb6831ced69f758c21e43d4021225a373c (patch)
treef5556cb4f5400f80cf6e7d76c76d46670d583c40 /meson.build
parent02b064a5915109027f29ee81d74288e9e7296ea5 (diff)
build: fix run_command warning
The default behavior of check: false is going to change to true in the future, see <https://github.com/mesonbuild/meson/issues/9300>. Thus we are explicit about the desired behavior. The error in uname is important but with test we check ourselves using returncode(). This fixes #556.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 326352ba..46879f2a 100644
--- a/meson.build
+++ b/meson.build
@@ -36,7 +36,7 @@ endif
option_os = get_option('os')
if option_os == ''
uname = find_program('uname')
- r = run_command(uname, '-s')
+ r = run_command(uname, '-s', check: true)
os = r.stdout().strip()
os = '-'.join(os.split('/'))
else
@@ -84,7 +84,7 @@ else
endif
if get_option('split-usr') == 'auto'
- split_usr = run_command('test', '-L', '/bin').returncode() != 0
+ split_usr = run_command('test', '-L', '/bin', check: false).returncode() != 0
else
split_usr = get_option('split-usr') == 'true'
endif