aboutsummaryrefslogtreecommitdiff
path: root/app-nvim/mason-nvim/mason-nvim-9999.ebuild
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-05 18:59:35 +0100
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-05 19:02:02 +0100
commit23544e126419753893f48082960796b65e60fc93 (patch)
treea5e4563270cf30ff9530bf6b65379563c995c7f0 /app-nvim/mason-nvim/mason-nvim-9999.ebuild
first batch of pluginsHEADmain
Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'app-nvim/mason-nvim/mason-nvim-9999.ebuild')
-rw-r--r--app-nvim/mason-nvim/mason-nvim-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-nvim/mason-nvim/mason-nvim-9999.ebuild b/app-nvim/mason-nvim/mason-nvim-9999.ebuild
new file mode 100644
index 0000000..f6f137c
--- /dev/null
+++ b/app-nvim/mason-nvim/mason-nvim-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+
+inherit neovim-plugin
+
+DESCRIPTION="Portable package manager for Neovim that runs everywhere Neovim runs. Easily install and manage LSP servers, DAP servers, linters, and formatters."
+HOMEPAGE="https://github.com/williamboman/mason.nvim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/williamboman/mason.nvim"
+else
+ SRC_URI="https://github.com/williamboman/mason.nvim/archive/refs/tags/v${PV}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"