summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-07-08 15:06:33 -0300
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-07-08 15:06:33 -0300
commit7a388dad85152a203033c14fee3c64607301865a (patch)
tree054b7bb03883576a8b68da8470908ff259e029d4 /meson.build
libactivity: (tmp name) http request parse
the parse works via callbacks, registered to a method and path. further work will be done to simplify extraction of path, and to make the request struct more private. missing the parsing and handling of reponses. Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..94299a9
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,12 @@
+project('activitypub', 'c',
+ license : 'GPLv3',
+ default_options : [
+ 'prefix=/usr',
+ 'warning_level=3'
+ ])
+
+jsondep = dependency('cJSON', required: true)
+
+incdir = include_directories('include/')
+
+subdir('src')