aboutsummaryrefslogtreecommitdiff
path: root/backend/libinput/touch.c
AgeCommit message (Collapse)Author
2024-02-29backend/libinput: use NULL to indicate missing device nameSimon Ser
libinput guarantees that the name is non-NULL, and an empty string if unset. However wlroots uses NULL to indicate that an input device name is unset.
2023-06-14backend/libinput: use struct initializers for eventsSimon Ser
This is more readable and consistent with the rest of wlroots.
2022-08-18Use wl_signal_emit_mutableAlexander Orzechowski
2022-03-17types/wlr_touch: uniformize events nameSimon Zeni
2022-03-17types/wlr_input_device: move width_mm and height_mm fields to wlr_tablet and ↵Simon Zeni
wlr_touch
2022-03-07interface/wlr_touch: rework destroy sequenceSimon Zeni
The destroy callback in wlr_touch_impl has been removed. The function `wlr_touch_finish` has been introduced to clean up the resources owned by a wlr_touch. `wlr_input_device_destroy` no longer destroys the wlr_touch, attempting to destroy a wlr_touch will result in a no-op. The field `name` has been added to the wlr_touch_impl to be able to identify a given wlr_touch device.
2022-03-02backend/libinput: rework touch interfaceSimon Zeni
The wlr_libinput_input_device now owns its wlr_touch, instead of creating a new wlr_libinput_input_device for it.
2022-02-21backend/libinput: remove wlr_input_device_implSimon Zeni
2022-02-21types/wlr_touch: add base wlr_input_deviceSimon Zeni
wlr_touch now owns its wlr_input_device. It will be initialized when the tablet tool is initialized, and finished when the touch is destroyed.
2021-07-08backend/libinput: send touch frame eventsSimon Ser
2019-08-19backend: touch: Fixup incomplete patch for single touch devices.Andri Yngvason
All instances of libinput_event_touch_get_slot need to be converted to libinput_event_touch_get_seat_slot for things to work.
2019-08-15backend: touch: Assign good ids to single touch devicesAndri Yngvason
libinput_event_touch_get_slot always returns -1 for single touch devices. Using libinput_event_touch_get_seat_slot instead ensures that they are assigned actual slot ids. Also, this is what Weston does, so this change yields a more consistent behaviour between different compositors.
2018-07-09util: add wlr_ prefix to log symbolsemersion
2018-04-25Make sure we don't use others' prefixesemersion
2018-04-25Remove wlr_ prefix from local symbolsemersion
2018-03-28Remove width_mm from wlr_touch eventsDrew DeVault
2018-02-12Reformat all #include directivesemersion
2018-02-12Make wlr_signal_emit_safe privateemersion
2018-02-12Add wlr_signal_emit_safeemersion
2017-11-16rename touch slot to touch idTony Crisci
2017-10-30remove time usecTony Crisci
2017-10-30refactor input time_sec to time_msecTony Crisci
2017-08-27add device to touch eventsTony Crisci
2017-08-14Refactor out wlr_touch_stateDominique Martinet
2017-08-13libinput backend: massive renamingDominique Martinet
- 'libinput' (backend's) to libinput_context - 'device' (libinput_device) to libinput_dev - 'dev' (wlr_device) to wlr_dev - 'devices' lists tangling of libinput devices to wlr_devices - 'devices' list of wlr_devices in backend state to wlr_device_lists
2017-08-11Build libinput events on the stack instead of allocatingDominique Martinet
2017-08-06Changed header paths.Scott Anderson
2017-06-21Make event names consistentDrew DeVault
2017-06-21Reorganize wlr-commonDrew DeVault
2017-06-21Update everyone to use new headersDrew DeVault
2017-06-14Flesh out touch events and add demoDrew DeVault
2017-06-14Allocate wlr_touch devicesDrew DeVault