aboutsummaryrefslogtreecommitdiff
path: root/xwayland/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'xwayland/meson.build')
-rw-r--r--xwayland/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/xwayland/meson.build b/xwayland/meson.build
index 09a7c6c2..bbf96eac 100644
--- a/xwayland/meson.build
+++ b/xwayland/meson.build
@@ -56,10 +56,9 @@ foreach lib, desc : xwayland_optional
required: get_option(lib),
not_found_message: '\n'.join(msg).format(lib),
)
- if dep.found()
- xwayland_libs += dep
- features += { lib: true }
- endif
+
+ internal_features += { lib: dep.found() }
+ xwayland_libs += dep
endforeach
wlr_files += files(