aboutsummaryrefslogtreecommitdiff
path: root/rootston/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'rootston/meson.build')
-rw-r--r--rootston/meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/rootston/meson.build b/rootston/meson.build
index 8ab872b5..9d1decce 100644
--- a/rootston/meson.build
+++ b/rootston/meson.build
@@ -11,12 +11,17 @@ sources = [
'seat.c',
'virtual_keyboard.c',
'wl_shell.c',
- 'xdg_shell_v6.c',
'xdg_shell.c',
+ 'xdg_shell_v6.c',
]
-if get_option('enable-xwayland')
- sources += ['xwayland.c']
+
+if conf_data.get('WLR_HAS_XWAYLAND', false)
+ sources += 'xwayland.c'
endif
+
executable(
- 'rootston', sources, dependencies: [wlroots, wlr_protos, pixman]
+ 'rootston',
+ sources,
+ dependencies: [wlroots, wlr_protos, pixman],
+ build_by_default: get_option('rootston'),
)