aboutsummaryrefslogtreecommitdiff
path: root/render/allocator/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'render/allocator/meson.build')
-rw-r--r--render/allocator/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/render/allocator/meson.build b/render/allocator/meson.build
new file mode 100644
index 00000000..db17ccb2
--- /dev/null
+++ b/render/allocator/meson.build
@@ -0,0 +1,9 @@
+wlr_files += files(
+ 'allocator.c',
+ 'gbm.c',
+ 'shm.c',
+ 'drm_dumb.c',
+)
+
+has = cc.has_function('gbm_bo_get_fd_for_plane', dependencies: [gbm])
+add_project_arguments('-DHAS_GBM_BO_GET_FD_FOR_PLANE=@0@'.format(has.to_int()), language: 'c')