aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 11 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 1ce9fbf4..3e33c9de 100644
--- a/meson.build
+++ b/meson.build
@@ -96,8 +96,17 @@ internal_features = {
'xcb-errors': false,
}
-wayland_server = dependency('wayland-server', version: '>=1.19')
-wayland_client = dependency('wayland-client')
+wayland_project_options = ['tests=false', 'documentation=false']
+wayland_server = dependency('wayland-server',
+ version: '>=1.19',
+ fallback: ['wayland', 'wayland_server_dep'],
+ default_options: wayland_project_options,
+)
+wayland_client = dependency('wayland-client',
+ fallback: ['wayland', 'wayland_client_dep'],
+ default_options: wayland_project_options,
+)
+
drm = dependency('libdrm', version: '>=2.4.105')
gbm = dependency('gbm', version: '>=17.1.0')
xkbcommon = dependency('xkbcommon')