aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 1 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 835e0195..3235dd3f 100644
--- a/meson.build
+++ b/meson.build
@@ -104,7 +104,7 @@ egl = dependency('egl')
glesv2 = dependency('glesv2')
drm = dependency('libdrm', version: '>=2.4.95')
gbm = dependency('gbm', version: '>=17.1.0')
-libinput = dependency('libinput', version: '>=1.9.0')
+libinput = dependency('libinput', version: '>=1.14.0')
xkbcommon = dependency('xkbcommon')
udev = dependency('libudev')
pixman = dependency('pixman-1')
@@ -133,13 +133,6 @@ wlr_deps = [
rt,
]
-libinput_ver = libinput.version().split('.')
-add_project_arguments([
- '-DLIBINPUT_MAJOR=' + libinput_ver[0],
- '-DLIBINPUT_MINOR=' + libinput_ver[1],
- '-DLIBINPUT_PATCH=' + libinput_ver[2],
-], language: 'c')
-
subdir('protocol')
subdir('render')