aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 12 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index db2e13e8..d31296f7 100644
--- a/meson.build
+++ b/meson.build
@@ -135,7 +135,6 @@ wlroots = declare_dependency(
include_directories: wlr_inc,
)
-
summary = [
'',
'----------------',
@@ -169,26 +168,31 @@ git = find_program('git', required: false)
if git.found()
all_files = run_command(
git,
- ['--git-dir=@0@/.git'.format(meson.current_source_dir()),
- 'ls-files',
- ':/*.[ch]'])
+ '--git-dir=@0@/.git'.format(meson.current_source_dir()),
+ 'ls-files',
+ ':/*.[ch]',
+ )
all_files = files(all_files.stdout().split())
etags = find_program('etags', required: false)
if etags.found() and all_files.length() > 0
- custom_target('etags',
+ custom_target(
+ 'etags',
build_by_default: true,
input: all_files,
output: 'TAGS',
- command: [etags.path(), '-o', 'TAGS'] + all_files)
+ command: [etags, '-o', '@OUTPUT@', '@INPUT@'],
+ )
endif
ctags = find_program('ctags', required: false)
if ctags.found() and all_files.length() > 0
- custom_target('ctags',
+ custom_target(
+ 'ctags',
build_by_default: true,
input: all_files,
output: 'tags',
- command: [ctags.path(), '-f', 'tags'] + all_files)
+ command: [ctags, '-f', '@OUTPUT@', '@INPUT@'],
+ )
endif
endif