aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 57c26b0f..179550d6 100644
--- a/meson.build
+++ b/meson.build
@@ -14,6 +14,10 @@ add_project_arguments(
'-DWLR_SRC_DIR="@0@"'.format(meson.source_root()),
language: 'c',
)
+add_project_arguments(
+ '-I@0@'.format(meson.build_root()),
+ language: 'c',
+)
add_project_link_arguments(
'-Wl,-rpath,@0@'.format(meson.build_root()),
language: 'c',
@@ -69,8 +73,8 @@ if elogind.found() and get_option('enable_elogind')
endif
subdir('protocol')
-subdir('backend')
subdir('render')
+subdir('backend')
subdir('types')
subdir('util')
subdir('xcursor')