aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 1 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index fc3f88af..0a584621 100644
--- a/meson.build
+++ b/meson.build
@@ -99,6 +99,7 @@ internal_features = {
'xcb-errors': false,
'egl': false,
}
+internal_config = configuration_data()
wayland_project_options = ['tests=false', 'documentation=false']
wayland_server = dependency('wayland-server',
@@ -158,13 +159,6 @@ subdir('xwayland')
subdir('include')
-foreach name, have : internal_features
- add_project_arguments(
- '-DHAS_@0@=@1@'.format(name.underscorify().to_upper(), have.to_int()),
- language: 'c',
- )
-endforeach
-
wlr_inc = include_directories('include')
proto_inc = include_directories('protocol')