aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ceded2d1..4a3c670a 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ xcb = dependency('xcb')
xcb_composite = dependency('xcb-composite')
libcap = dependency('libcap', required: false)
systemd = dependency('libsystemd', required: false)
+elogind = dependency('libelogind', required: false)
math = cc.find_library('m', required: false)
if libcap.found() and get_option('enable_libcap')
@@ -56,6 +57,10 @@ if systemd.found() and get_option('enable_systemd')
add_project_arguments('-DHAS_SYSTEMD', language: 'c')
endif
+if elogind.found() and get_option('enable_elogind')
+ add_project_arguments('-DHAS_ELOGIND', language: 'c')
+endif
+
subdir('protocol')
subdir('backend')
subdir('render')