aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5095e877..560a14ad 100644
--- a/meson.build
+++ b/meson.build
@@ -17,8 +17,13 @@ project(
# between minor releases.
soversion = 9
+little_endian = host_machine.endian() == 'little'
+big_endian = host_machine.endian() == 'big'
+
add_project_arguments([
'-DWLR_USE_UNSTABLE',
+ '-DWLR_LITTLE_ENDIAN=@0@'.format(little_endian.to_int()),
+ '-DWLR_BIG_ENDIAN=@0@'.format(big_endian.to_int()),
], language: 'c')
cc = meson.get_compiler('c')