aboutsummaryrefslogtreecommitdiff
path: root/include/wlr/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'include/wlr/meson.build')
-rw-r--r--include/wlr/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/include/wlr/meson.build b/include/wlr/meson.build
index 14551cb4..43b5aec9 100644
--- a/include/wlr/meson.build
+++ b/include/wlr/meson.build
@@ -4,14 +4,13 @@ version_data.set_quoted('WLR_VERSION_STR', meson.project_version())
version_data.set('WLR_VERSION_MAJOR', version_array[0])
version_data.set('WLR_VERSION_MINOR', version_array[1])
version_data.set('WLR_VERSION_MICRO', version_array[2])
-version_data.set('WLR_VERSION_NUM', '(WLR_VERSION_MAJOR << 16) | (WLR_VERSION_MINOR << 8) | WLR_VERSION_MICRO')
version_data.set('WLR_VERSION_API_CURRENT', so_version[0])
version_data.set('WLR_VERSION_API_REVISION', so_version[1])
version_data.set('WLR_VERSION_API_AGE', so_version[2])
install_headers(
- configure_file(output: 'config.h', configuration: conf_data),
- configure_file(output: 'version.h', configuration: version_data),
+ configure_file(input: 'config.h.in', output: 'config.h',configuration: conf_data),
+ configure_file(input: 'version.h.in', output: 'version.h', configuration: version_data),
'backend.h',
'xcursor.h',
subdir: 'wlr'