aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build24
1 files changed, 18 insertions, 6 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 152453ae..140fd078 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -8,11 +8,21 @@ all_libs = [
lib_wlr,
]
-executable('simple', 'simple.c', link_with: all_libs)
-executable('rotation', 'rotation.c', link_with: all_libs)
-executable('pointer', 'pointer.c', link_with: all_libs)
-executable('touch', 'touch.c', link_with: all_libs)
-executable('tablet', 'tablet.c', link_with: all_libs)
+executable('simple', 'simple.c',
+ dependencies: dep_wlr,
+ link_with: all_libs)
+executable('rotation', 'rotation.c',
+ dependencies: dep_wlr,
+ link_with: all_libs)
+executable('pointer', 'pointer.c',
+ dependencies: dep_wlr,
+ link_with: all_libs)
+executable('touch', 'touch.c',
+ dependencies: dep_wlr,
+ link_with: all_libs)
+executable('tablet', 'tablet.c',
+ dependencies: dep_wlr,
+ link_with: all_libs)
compositor_src = [
'compositor/main.c',
@@ -20,4 +30,6 @@ compositor_src = [
'compositor/wl_shell.c',
]
-executable('compositor', compositor_src, link_with: all_libs)
+executable('compositor', compositor_src,
+ dependencies: dep_wlr,
+ link_with: all_libs)