aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index d8df0bfc..18f44fde 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,6 +1,8 @@
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
+libpng = dependency('libpng', required: false)
+
# These versions correspond to ffmpeg 4.0
libavutil = dependency('libavutil', version: '>=56.14.100', required: false)
libavcodec = dependency('libavcodec', version: '>=58.18.100', required: false)
@@ -56,3 +58,11 @@ if libavutil.found() and libavcodec.found() and libavformat.found()
libavformat, wlroots, threads ]
)
endif
+
+if libpng.found()
+ executable(
+ 'screencopy',
+ 'screencopy.c',
+ dependencies: [wayland_client, wlr_protos, wlroots, libpng]
+ )
+endif