aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index f0ebad64..9fee0596 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -223,3 +223,14 @@ foreach name, info : clients
build_by_default: get_option('examples'),
)
endforeach
+
+executable(
+ 'embedded',
+ [
+ 'embedded.c',
+ 'egl_common.c',
+ protocols_code['xdg-shell'],
+ protocols_client_header['xdg-shell'],
+ ],
+ dependencies: [wlroots, wayland_client, wayland_egl, egl, glesv2],
+)