aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index a83def8f..9e60c37a 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -6,6 +6,7 @@ lib_shared = static_library(
)
threads = dependency('threads')
+wayland_cursor = dependency('wayland-cursor')
executable('simple', 'simple.c', dependencies: wlroots, link_with: lib_shared)
executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
@@ -48,3 +49,9 @@ executable(
dependencies: [wayland_client, wlr_protos, wlroots, threads],
link_with: lib_shared,
)
+
+executable(
+ 'layer-shell',
+ 'layer-shell.c',
+ dependencies: [wayland_cursor, wayland_client, wlr_protos, wlroots]
+)