aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build38
1 files changed, 9 insertions, 29 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 646a4b88..e3f9cf84 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,39 +1,19 @@
lib_shared = static_library('shared',
['shared.c', 'cat.c'],
- dependencies: dep_wlr)
+ dependencies: wlroots)
-executable('simple', 'simple.c', dependencies: dep_wlr, link_with: lib_shared)
-executable('rotation', 'rotation.c', dependencies: dep_wlr, link_with: lib_shared)
-executable('pointer', 'pointer.c', dependencies: dep_wlr, link_with: lib_shared)
-executable('touch', 'touch.c', dependencies: dep_wlr, link_with: lib_shared)
-executable('tablet', 'tablet.c', dependencies: dep_wlr, link_with: lib_shared)
-
-wayland_scanner = find_program('wayland-scanner')
-wl_protocol_dir = dep_wayland_proto.get_pkgconfig_variable('pkgdatadir')
-
-wayland_scanner_server = generator(wayland_scanner,
- output: '@BASENAME@-protocol.h',
- arguments: ['server-header', '@INPUT@', '@OUTPUT@'])
-
-wayland_scanner_code = generator(wayland_scanner,
- output: '@BASENAME@-protocol.c',
- arguments: ['code', '@INPUT@', '@OUTPUT@'])
+executable('simple', 'simple.c', dependencies: wlroots, link_with: lib_shared)
+executable('rotation', 'rotation.c', dependencies: wlroots, link_with: lib_shared)
+executable('pointer', 'pointer.c', dependencies: wlroots, link_with: lib_shared)
+executable('touch', 'touch.c', dependencies: wlroots, link_with: lib_shared)
+executable('tablet', 'tablet.c', dependencies: wlroots, link_with: lib_shared)
compositor_src = [
'compositor/main.c',
'compositor/wl_compositor.c',
'compositor/wl_shell.c',
- 'compositor/xdg_shell.c',
]
-protocols = [
- [ 'unstable', 'xdg-shell', 'xdg-shell-unstable-v6.xml' ]
-]
-
-foreach p : protocols
- xml = join_paths([wl_protocol_dir] + p)
- compositor_src += wayland_scanner_code.process(xml)
- compositor_src += wayland_scanner_server.process(xml)
-endforeach
-
-executable('compositor', compositor_src, dependencies: dep_wlr, link_with: lib_shared)
+executable('compositor', compositor_src,
+ dependencies: wlroots,
+ link_with: lib_shared)