aboutsummaryrefslogtreecommitdiff
path: root/examples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/meson.build')
-rw-r--r--examples/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/examples/meson.build b/examples/meson.build
index 4725b989..d82bd256 100644
--- a/examples/meson.build
+++ b/examples/meson.build
@@ -1,6 +1,10 @@
threads = dependency('threads')
wayland_cursor = dependency('wayland-cursor')
+libavutil = dependency('libavutil', required: false)
+libavcodec = dependency('libavcodec', required: false)
+libavformat = dependency('libavformat', required: false)
+
executable('simple', 'simple.c', dependencies: wlroots)
executable('pointer', 'pointer.c', dependencies: wlroots)
executable('touch', 'touch.c', 'cat.c', dependencies: wlroots)
@@ -38,3 +42,11 @@ executable(
'input-inhibitor.c',
dependencies: [wayland_cursor, wayland_client, wlr_protos, wlroots]
)
+
+if libavutil.found() and libavcodec.found() and libavformat.found()
+ executable(
+ 'dmabuf-capture',
+ 'dmabuf-capture.c',
+ dependencies: [wayland_client, wlr_protos, libavutil, libavcodec, libavformat]
+ )
+endif