aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
index e8f7ec72..fff2e49b 100644
--- a/example/CMakeLists.txt
+++ b/example/CMakeLists.txt
@@ -1,19 +1,23 @@
include_directories(
${DRM_INCLUDE_DIRS}
${CMAKE_CURRENT_SOURCE_DIR}
+ ${XKBCOMMON_INCLUDE_DIRS}
)
add_executable(simple
simple.c
+ shared.c
)
target_link_libraries(simple
wlr-backend
wlr-session
+ ${XKBCOMMON_LIBRARIES}
)
add_executable(rotation
rotation.c
+ shared.c
cat.c
)
@@ -21,4 +25,43 @@ target_link_libraries(rotation
wlr-backend
wlr-session
wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(pointer
+ pointer.c
+ shared.c
+ cat.c
+)
+
+target_link_libraries(pointer
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(touch
+ touch.c
+ shared.c
+ cat.c
+)
+
+target_link_libraries(touch
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
+)
+
+add_executable(tablet
+ tablet.c
+ shared.c
+)
+
+target_link_libraries(tablet
+ wlr-backend
+ wlr-session
+ wlr-render
+ ${XKBCOMMON_LIBRARIES}
)