aboutsummaryrefslogtreecommitdiff
path: root/backend/x11/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/x11/meson.build')
-rw-r--r--backend/x11/meson.build11
1 files changed, 0 insertions, 11 deletions
diff --git a/backend/x11/meson.build b/backend/x11/meson.build
index 04111a13..d9fd8d91 100644
--- a/backend/x11/meson.build
+++ b/backend/x11/meson.build
@@ -4,9 +4,6 @@ x11_required = [
'xcb',
'xcb-xinput',
]
-x11_optional = [
- 'xcb-xkb',
-]
foreach lib : x11_required
dep = dependency(lib, required: get_option('x11-backend'))
@@ -17,14 +14,6 @@ foreach lib : x11_required
x11_libs += dep
endforeach
-foreach lib : x11_optional
- dep = dependency(lib, required: get_option(lib))
- if dep.found()
- x11_libs += dep
- conf_data.set10('WLR_HAS_' + lib.underscorify().to_upper(), true)
- endif
-endforeach
-
lib_wlr_backend_x11 = static_library(
'wlr_backend_x11',
files(