aboutsummaryrefslogtreecommitdiff
path: root/backend/session/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/session/meson.build')
-rw-r--r--backend/session/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/backend/session/meson.build b/backend/session/meson.build
index 140d4105..29fcf6e4 100644
--- a/backend/session/meson.build
+++ b/backend/session/meson.build
@@ -33,7 +33,7 @@ if get_option('logind-provider') == 'auto'
version: logind_version,
)
if logind.found()
- conf_data.set10('WLR_HAS_SYSTEMD', true)
+ features += { 'systemd': true }
else
logind = dependency('libelogind',
required: get_option('logind'),
@@ -41,7 +41,7 @@ if get_option('logind-provider') == 'auto'
version: logind_version,
)
if logind.found()
- conf_data.set10('WLR_HAS_ELOGIND', true)
+ features += { 'elogind': true }
endif
endif
logind_found = logind.found()
@@ -53,7 +53,7 @@ else
version: logind_version,
)
if logind.found()
- conf_data.set10('WLR_HAS_' + get_option('logind-provider').to_upper(), true)
+ features += { get_option('logind-provider'): true }
logind_found = true
endif
endif
@@ -69,5 +69,5 @@ libseat = dependency('libseat', required: get_option('libseat'), version: '>=0.2
if libseat.found()
wlr_files += files('libseat.c')
wlr_deps += libseat
- conf_data.set10('WLR_HAS_LIBSEAT', true)
+ features += { 'libseat': true }
endif