aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/backend/meson.build b/backend/meson.build
index a74ea024..52abe64d 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -50,7 +50,12 @@ if conf_data.get('WLR_HAS_SYSTEMD', false)
endif
if conf_data.get('WLR_HAS_X11_BACKEND', false)
- backend_files += files('x11/backend.c')
+ backend_files += files(
+ 'x11/backend.c',
+ 'x11/input_device.c',
+ 'x11/output.c',
+ )
+ backend_deps += xcb_xkb
endif
if conf_data.get('WLR_HAS_ELOGIND', false)