aboutsummaryrefslogtreecommitdiff
path: root/backend/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/meson.build')
-rw-r--r--backend/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/backend/meson.build b/backend/meson.build
index eb8c5d8b..a3cb7b64 100644
--- a/backend/meson.build
+++ b/backend/meson.build
@@ -28,9 +28,13 @@ if systemd.found()
backend_files += files('session/logind.c')
endif
+if elogind.found()
+ backend_files += files('session/logind.c')
+endif
+
lib_wlr_backend = static_library(
'wlr_backend',
backend_files,
include_directories: wlr_inc,
- dependencies: [wayland_server, egl, gbm, libinput, systemd, wlr_protos],
+ dependencies: [wayland_server, egl, gbm, libinput, systemd, elogind, wlr_protos],
)