aboutsummaryrefslogtreecommitdiff
path: root/backend/libinput/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/libinput/meson.build')
-rw-r--r--backend/libinput/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/backend/libinput/meson.build b/backend/libinput/meson.build
index 181eb04b..368ae0f9 100644
--- a/backend/libinput/meson.build
+++ b/backend/libinput/meson.build
@@ -29,7 +29,5 @@ features += { 'libinput-backend': true }
wlr_deps += libinput
# libinput hold gestures and high resolution scroll are available since 1.19.0
-add_project_arguments([
- '-DLIBINPUT_HAS_HOLD_GESTURES=@0@'.format(libinput.version().version_compare('>=1.19.0').to_int()),
- '-DLIBINPUT_HAS_SCROLL_VALUE120=@0@'.format(libinput.version().version_compare('>=1.19.0').to_int()),
-], language: 'c')
+internal_config.set10('LIBINPUT_HAS_HOLD_GESTURES', libinput.version().version_compare('>=1.19.0'))
+internal_config.set10('LIBINPUT_HAS_SCROLL_VALUE120', libinput.version().version_compare('>=1.19.0'))