aboutsummaryrefslogtreecommitdiff
path: root/backend/libinput/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'backend/libinput/meson.build')
-rw-r--r--backend/libinput/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/backend/libinput/meson.build b/backend/libinput/meson.build
index 44bb57e1..38ba05f1 100644
--- a/backend/libinput/meson.build
+++ b/backend/libinput/meson.build
@@ -27,3 +27,9 @@ wlr_files += files(
features += { 'libinput-backend': true }
wlr_deps += libinput
+
+# libinput hold gestures are available since 1.19.0
+add_project_arguments(
+ '-DLIBINPUT_HAS_HOLD_GESTURES=@0@'.format(libinput.version().version_compare('>=1.19.0').to_int()),
+ language: 'c',
+)