aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
index 91f0f06e..9594c318 100644
--- a/backend/CMakeLists.txt
+++ b/backend/CMakeLists.txt
@@ -2,6 +2,7 @@ include_directories(
${PROTOCOLS_INCLUDE_DIRS}
${WAYLAND_INCLUDE_DIR}
${DRM_INCLUDE_DIRS}
+ ${LIBINPUT_INCLUDE_DIRS}
)
add_library(wlr-backend
@@ -9,11 +10,22 @@ add_library(wlr-backend
#wayland/registry.c
#wayland/wl_seat.c
#wayland/wl_output.c
+
drm/backend.c
drm/drm.c
- udev.c
+
+ libinput/backend.c
+ libinput/events.c
+ libinput/keyboard.c
+ libinput/pointer.c
+ libinput/touch.c
+ libinput/tablet_tool.c
+ libinput/tablet_pad.c
+
+ multi/backend.c
backend.c
egl.c
+ udev.c
)
target_link_libraries(wlr-backend
@@ -26,5 +38,6 @@ target_link_libraries(wlr-backend
${EGL_LIBRARIES}
${SYSTEMD_LIBRARIES}
${UDEV_LIBRARIES}
+ ${LIBINPUT_LIBRARIES}
${GBM_LIBRARIES}
)