aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt21
1 files changed, 17 insertions, 4 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
index 830a2158..fc1793cf 100644
--- a/backend/CMakeLists.txt
+++ b/backend/CMakeLists.txt
@@ -1,17 +1,30 @@
include_directories(
${PROTOCOLS_INCLUDE_DIRS}
${WAYLAND_INCLUDE_DIR}
+ ${DRM_INCLUDE_DIRS}
)
add_library(wlr-backend
- wayland/backend.c
- wayland/registry.c
- wayland/wl_seat.c
- wayland/wl_output.c
+ #wayland/backend.c
+ #wayland/registry.c
+ #wayland/wl_seat.c
+ #wayland/wl_output.c
+ drm/backend.c
+ drm/drm.c
+ drm/udev.c
+ backend.c
+ egl.c
)
target_link_libraries(wlr-backend
wlr-common
wlr-wayland
${WAYLAND_LIBRARIES}
+ ${DRM_LIBRARIES}
+ ${GBM_LIBRARIES}
+ ${GLESv2_LIBRARIES}
+ ${EGL_LIBRARIES}
+ ${SYSTEMD_LIBRARIES}
+ ${UDEV_LIBRARIES}
+ ${GBM_LIBRARIES}
)