aboutsummaryrefslogtreecommitdiff
path: root/backend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'backend/CMakeLists.txt')
-rw-r--r--backend/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/backend/CMakeLists.txt b/backend/CMakeLists.txt
index 830a2158..c962b8ed 100644
--- a/backend/CMakeLists.txt
+++ b/backend/CMakeLists.txt
@@ -1,6 +1,7 @@
include_directories(
${PROTOCOLS_INCLUDE_DIRS}
${WAYLAND_INCLUDE_DIR}
+ ${DRM_INCLUDE_DIRS}
)
add_library(wlr-backend
@@ -8,6 +9,11 @@ add_library(wlr-backend
wayland/registry.c
wayland/wl_seat.c
wayland/wl_output.c
+ drm/drm.c
+ drm/event.c
+ drm/otd.c
+ drm/session.c
+ drm/udev.c
)
target_link_libraries(wlr-backend