aboutsummaryrefslogtreecommitdiff
path: root/xwayland/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-06-25 13:49:47 +0200
committerKenny Levinsen <kl@kl.wtf>2022-05-07 19:25:44 +0000
commitf575e445ec36dec5fe7f5674a4dae8096a833d6f (patch)
tree9b0a7594a5543ed99d205e1aee643169a60e5435 /xwayland/meson.build
parent352064d76d459b499b39a99f889f96f40987f0e9 (diff)
xwayland: terminate when no client is connected
Automatically shutdown Xwayland 10s after all X11 clients have gone away.
Diffstat (limited to 'xwayland/meson.build')
-rw-r--r--xwayland/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/xwayland/meson.build b/xwayland/meson.build
index b7bbcaf1..4d8ed5f4 100644
--- a/xwayland/meson.build
+++ b/xwayland/meson.build
@@ -74,3 +74,9 @@ wlr_files += files(
)
wlr_deps += xwayland_libs
features += { 'xwayland': true }
+
+have = cc.has_function('xcb_xfixes_set_client_disconnect_mode', dependencies: xwayland_libs)
+add_project_arguments(
+ '-DHAS_XCB_XFIXES_SET_CLIENT_DISCONNECT_MODE=@0@'.format(have.to_int()),
+ language: 'c',
+)