aboutsummaryrefslogtreecommitdiff
path: root/xwayland/meson.build
diff options
context:
space:
mode:
authorAleksei Bavshin <alebastr89@gmail.com>2021-04-16 19:27:12 -0700
committerSimon Ser <contact@emersion.fr>2021-04-23 09:55:01 +0200
commite0f239fa2828318e9eff6b68f7faafecd338914c (patch)
treeb871ac9fffed0a3aebe3a2c73a9aa389675db1d4 /xwayland/meson.build
parentc314920a3d2bcb347d9ae491a678d8349f32ae8d (diff)
xwayland: query window PIDs via XResQueryClientIds
`_NET_WM_PID` is unreliable: it is optional and even if set it may contain PIDs from sandbox namespaces or remote systems. Prefer XRes v1.2 QueryClientIds method which returns PIDs as seen by the Xwayland server.
Diffstat (limited to 'xwayland/meson.build')
-rw-r--r--xwayland/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/xwayland/meson.build b/xwayland/meson.build
index bbf96eac..b7bbcaf1 100644
--- a/xwayland/meson.build
+++ b/xwayland/meson.build
@@ -4,6 +4,7 @@ xwayland_required = [
'xcb-composite',
'xcb-icccm',
'xcb-render',
+ 'xcb-res',
'xcb-xfixes',
]
xwayland_optional = {