aboutsummaryrefslogtreecommitdiff
path: root/xwayland/meson.build
diff options
context:
space:
mode:
authoremersion <contact@emersion.fr>2018-11-12 10:12:46 +0100
committeremersion <contact@emersion.fr>2018-11-12 10:12:46 +0100
commit51bfdd620e70c41e1a9fb4ce7831eddfb1bf893b (patch)
treef32586aa88e18d9bfec7cbcbeb5c682b2f35fb4a /xwayland/meson.build
parent3181c4bec06d2fe51da052c0a08c8287725ec900 (diff)
Use #if instead of #ifdef for wlroots config data
This prevents some annoying issues when e.g. not including wlr/config.h or making a typo in the guard name.
Diffstat (limited to 'xwayland/meson.build')
-rw-r--r--xwayland/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/xwayland/meson.build b/xwayland/meson.build
index 0bd88924..e5f9b9be 100644
--- a/xwayland/meson.build
+++ b/xwayland/meson.build
@@ -23,7 +23,7 @@ foreach lib : xwayland_optional
dep = dependency(lib, required: get_option(lib))
if dep.found()
xwayland_libs += dep
- conf_data.set('WLR_HAS_' + lib.underscorify().to_upper(), true)
+ conf_data.set10('WLR_HAS_' + lib.underscorify().to_upper(), true)
endif
endforeach
@@ -48,4 +48,4 @@ lib_wlr_xwayland = static_library(
)
wlr_parts += lib_wlr_xwayland
-conf_data.set('WLR_HAS_XWAYLAND', true)
+conf_data.set10('WLR_HAS_XWAYLAND', true)