aboutsummaryrefslogtreecommitdiff
path: root/xwayland/meson.build
diff options
context:
space:
mode:
authorSimon Ser <contact@emersion.fr>2021-04-06 11:59:57 +0200
committerKenny Levinsen <kl@kl.wtf>2021-04-09 21:54:38 +0200
commit1eb38e001503636a8e5058051e9256d70f1bffcc (patch)
treec33d204acec48d036a60033de949519f4c58abe8 /xwayland/meson.build
parent78befa59f96bb0a13e9ffeb4df1272738c6b5012 (diff)
Remove WLR_HAS_XCB_ERRORS
wlroots' dependency on this library doesn't change the features exposed to compositors. It's purely a wlroots implementation detail. Thus downstream compositors shouldn't really care about it. Introduce an "internal_features" dictionary to store the status of such internal dependencies.
Diffstat (limited to 'xwayland/meson.build')
-rw-r--r--xwayland/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/xwayland/meson.build b/xwayland/meson.build
index 09a7c6c2..bbf96eac 100644
--- a/xwayland/meson.build
+++ b/xwayland/meson.build
@@ -56,10 +56,9 @@ foreach lib, desc : xwayland_optional
required: get_option(lib),
not_found_message: '\n'.join(msg).format(lib),
)
- if dep.found()
- xwayland_libs += dep
- features += { lib: true }
- endif
+
+ internal_features += { lib: dep.found() }
+ xwayland_libs += dep
endforeach
wlr_files += files(